Патчи безопасности для версии 9.7

Обновленный патч безопасности устраняющий все обнаруженные ранее для версии 9.7 проблемы безопасности. В дополнение от выпущенных ранее патчей для версии 9.7, в данном патче используется более улучшенный алгоритм в фильтрации шаблонов, позволяющий устранить некоторые несовместимости со сторонними модулями и ряд некоторых других проблем, связанных исключительно с версией 9.7. А также был изменен алгоритм загрузки картинок и автаров, который больше не позволяет использование анимированных картинок .gif. Все загружаемые анимированные картинки будут выводится в виде статических картинок. Данная мера является вынужденной и необходимой, в связи с рядом ограничений формата gif, который не позволяет в достаточной мере отфильтровать вредный код в картинках, единственным эффективным способом является только снятие поддержки анимации в данных картинках.

Ошибка в версии: только 9.7.

Степень опасности: Высокая

Для исправления скачайте и скопируйте на свой сервер патч: http://dle-news.ru/files/dle97_path.zip

Данный патч предназначен только для версии 9.7 является общим и включающим в себя также и патчи, ранее выпускавшиеся для версии 9.7. Если вы используете другую версию скрипта, отличную от версии 9.7, то вам нужно смотреть другие патчи, выпущенные в разделе: http://dle-news.ru/bags/.

Источник: http://dle-news.ru/bags/v97/1549-patchi-bezopasnosti-dlya-versii-97.html

Недостаточная фильтрация данных в парсере шаблонов

Проблема: Недостаточная фильтрация данных в парсере шаблонов.

Ошибка в версии: 9.7 и все более ранние версии

Степень опасности: Высокая

Для исправления проблемы установите патч, предназначенный для всех версий скрипта.

Источник: http://dle-news.ru/bags/v97/1547-patchi-bezopasnosti-dlya-versiy-97-i-nizhe.html

Патчи безопасности для версий 9.7 и ниже

Проблема: Проведение SQL инъекций, в случае игнорирования администратором сайта уведомления в админпанели скрипта, о недопустимости включения на сервере небезопасной настройки register_globals, а также возможность обхода кода безопасности CAPTCHA при регистрации.

Ошибка в версии: 9.7 и все более ранние версии

Степень опасности: Высокая при использовании включенной настройки register_globals, отсутствует при выполнении рекомендаций по отключению данной настройки в настройках сервера. Установка патча тем не менее обязательна для всех, т.к. патч устраняет возможный обход каптчи и другие проблемы.

Источник: http://dle-news.ru/bags/v97/1538-patchi-bezopasnosti-dlya-versiy-97-i-nizhe.html

© 2009 Обзор CMS